1and1 Help Centre Categories

print article

Which browsers are compatible with WebsiteCreator?

WebsiteCreator is compatible with the following web browsers:

  • Internet Explorer (version 5.5 or higher) for Windows
  • Mozilla (version 1.4 or higher) for Windows
  • Netscape (version 7.1 or higher) for Windows
  • Mozilla for Mac

Problems may occur when using older browser versions because they may not be able to process the WebsiteCreator technology. Should a blank page appear when launching WebsiteCreator, or a page full of placeholder icons appears instead of the editing window after calling up the edit function, we recommend downloading the latest browser version of Netscape or Microsoft and then carry out a full installation so that all required plug-ins are also installed. Afterwards you should experience no problems using WebsiteCreator.